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Abstract  
 

Soil yielding mechanisms and seismic load responses are the key areas of study. The true behavior of soil is revealed by 

nonlinear analysis. A clump of dirt is used for the analysis. In this study, the Finite Element Model (FEM) forms the 

basis for the mathematical formulas. Soil analysis in the case of a lumped mass takes into account the soil's one DOF, 

two DOF, and multi DOF degrees of freedom. In order to determine soil characteristics for MDOF, a soil bore log must 

be employed. In the instance of MDOF, the soil is composed of 12 distinct layers. SAP 2000 is used to conduct a 

nonlinear time-history analysis for this research. The hysteresis loops of nonlinear elastic, completely flexible soil 

undergo permanent deformation. Therefore, it is possible to get insight into the behavior of soil mass during an 

earthquake by studying lumped soil mass. The soil's nonlinear behavior is investigated using a variety of linear 

completely plastic hysteretic loops. Soil characteristics are shown to be crucial in this regard. Inadequate soil stiffness 

may result in persistent deformation, which in turn can lead structures to lean out of alignment. It is also noted that near 

the soil's surface, amplification is greatest. 
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INTRODUCTION 
Bangladesh is a populated country. There are 

several active tectonic plate boundaries in Bangladesh. 

Active faults such as those in the north and east of 

Bangladesh can be destructive. Also, it is very close to 

sea level and largest river delta in the world. Scientists 

predict it is a matter of time to occur a large earthquake 

[1]. Earthquake is frequently found to govern structural 

designs and many buildings are badly affected by 

tilting. Performance of foundations often degenerates 

during ground shaking. Differential settlements are the 

main reason causing tilting of the building. This refers 

to uneven load deformation behavior, which can be 

referred as asymmetric behavior also. It will happen 

when buildings display distinctive plastic yield 

scenarios. Then again, plastic deformation counteracts 

each other in the symmetric buildings when excited to 

seismic loading. But plastic deformations form in the 

direction of tilting for asymmetric yielding buildings 

when they are excited by seismic loading. It can be said 

more clearly that strong and weak ways will develop 

due to tilting for symmetric buildings. This kind of 

symmetrical building is not always possible in reality. 

That’s why most of the buildings generate different 

yield strength in opposite directions. It damages the 

building significantly if the buildings are subjected to 

long duration seismic ground motions. 

 

A 7.8 earthquake (Gorkha earthquake) struck 

Nepal on 25th April, 2015. Convergent collision plate 

boundaries between the Indian and Eurasian plates 

created this earthquake. The epicenter was just 60 

kilometers north-west from the capital Kathmandu and 

the focus was only eight kilometers deep. About 9000 

people were killed and over 20,000 were injured, while 

more than 600,000 structures in Kathmandu and other 

nearby towns were either damaged or destroyed 

(rendering more 3.5 million people homeless) [2]. It 

also damaged several structures in Bangladesh. 

 

The performance of foundations is a major 

concern in soil mechanics and foundation engineering 

since every building must rest on the ground eventually. 

Static, dynamic, or even combined stresses may cause 

problems for a building's underpinnings [3]. A dynamic 

load may be the result of an earthquake, the application 

of cyclic loads with varying cycle numbers, or any other 
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sort of load that varies over time. Damage to 

geotechnical structures, such as liquefaction, slope 

instability, deformation of retaining walls, and damage 

to foundations by diminishing bearing capacity and 

increasing sinking, may be caused by a significant 

dynamic load. A foundation's stress state near the floor 

transitions from elastic to plastic as a load is applied; 

plastic flow initiates at a corner of the foundation and 

spreads outward along a curved surface as the load 

increases, eventually covering the soil beneath the 

structure entirely [4-6]. Due to the complexity of 

dynamic force and soil behavior under the impact of 

these forces, the dynamic bearing capacity of 

foundations has been researched less than its static 

counterpart [7]. 

 

In this study we will see the performance of 

nonlinear dynamic analysis of lumped soil mass model 

against seismic loading. 

 

The mathematical expressions used in this 

paper are based on the Finite Element Model (FEM). 

One degree of freedom (1DOF), two degrees of 

freedom (2DOF) and multi degree of freedom (MDOF) 

of soil considered for analysis in case of lumped mass. 

A soil bore log is used to calculate soil parameters for 

MDOF. There are twelve layers of soil in case of 

MDOF. Time history nonlinear analysis is done by SAP 

2000 for this study. Permanent deformation is observed 

for nonlinear elastic, perfectly plastic hysteresis loops in 

lumped soil mass. So lumped soil mass can be used to 

understand the behavior of soil mass during the 

earthquake. 

 

OBJECTIVE OF THE STUDY 
• To see the performance of nonlinear dynamic 

analysis of lumped soil mass model against 

seismic loading.  

 

NUMERICAL MODELING OF SUB-

STRUCTURE 
Ground shaking is a non-periodic dynamic 

load which varies with time. It describes the vibration 

of the ground during an earthquake. It generates the 

rapid acceleration of the ground beneath the building 

which creates inertial forces in the structure. This can 

cause damage or may tilt the foundation if acceleration 

becomes too large.  

 

This study evaluates the nonlinear analysis of 

lumped mass. Analysis of soil mass mainly focuses on 

displacement of the soil mass during ground shaking. It 

also includes earthquake wave propagation, soil 

amplification and soil-structure interaction. 

 

If mathematical models are too complex to 

provide analytical solutions especially in nonlinear 

system, then numerical modeling is required to study 

the behavior of the system. It implements mathematical 

model for a physical system. This study includes the 

numerical design approaches for characterization the 

soil behavior under a structure during earthquake. 

 

Finite Elements Model 

This analysis is used Finite Elements Model 

(FEM) method for numerical simulations. It is 

numerical procedure to determine the stresses and strain 

which includes complex engineering problems. It is a 

method by solving partial differential equations in two 

or three space variables which includes some boundary 

value problems. The FEM subdivides a large system 

into smaller, simpler parts to solve a problem that are 

named finite elements. 

 

Lumped spring and Mass Model 

Degree of freedom (DOF) of a system is 

defined as the number of independent variables required 

to completely determine the positions of all parts of a 

system at any instant of time. Some systems, especially 

those involving continuous elastic members, have an 

infinite number of DOF. As an example of this is a soil 

layers.  

 

 
 

Soil layers 

This soil layers has infinite mass points and 

need infinite number of displacements to draw its 

deflected shape and thus has an infinite DOF. Systems 

with infinite DOF are called continuous or distributed 

systems. Analysis with this distributed system may be 

named as mass model. 

 

On the other hand, Systems with a finite 

number of degrees of freedom are called Discrete or 

Lumped mass parameter systems.  

 

 
Lumped mass parameter systems 
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In a single degree of freedom system, the 

deformation of the entire structure can be described by 

a single number equal to the displacement of a point 

from an at-rest position. Single Degree of freedom 

systems do not normally exist in real life. We live in a 

three-dimensional world and all mass is distributed 

resulting in systems that have an infinite number of 

degrees of freedom. There are, however, instances 

where a structure may be approximated as a single 

degree of freedom system. In a Multi degree of freedom 

system, the deformation of the entire structure cannot 

be described by a single displacement. More than one 

displacement coordinates are required to completely 

specify the displaced shape. 

 

 
Multi degree of freedom system 

 

RESULTS 
Structural dynamics is needed to perform 

seismic analysis. Non-linear analysis is also needed to 

know the actual behavior of soil. This study also 

includes time history analysis for which data is 

produced from UAP experimental work. This chapter 

includes the numerical results obtained from using 

software SAP 2000.  

 

Sub-Structure Models used for Analysis: 

Nonlinear analysis is performed for multi 

degree of freedom (MDOF) only. All soil parameters 

are calculated from this bore log. Here also three meter 

by three meter (3×3) area and 1.5 m thickness each 

layer soil mass as per bore log is considered for 

analysis. 18 m in total depth is considered from existing 

ground level and total 12 layers are used. Each layer is 

as shown in Fig. 1.  

 

 
Fig. 1: Soil layers for MDOF 

 

In this study ground motion data are used from 

UAP laboratory test (Fig. 2) which was performed for 

20-seconds for time history analysis. 

 

 
Fig. 2: Time history data 
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Table 1: Soil Parameters for MDOF (Nonlinear Analysis) 

 
 

Lumped Spring Model for Nonlinear Analysis 

1. Go to the File Menu > New Model > Select Unit > Click Grid only  

 

 
Fig. 3: Defining model for lumped mass nonlinear analysis 

 



 
 

S. M. Tahmidur Rahman., Saudi J Civ Eng, Sep, 2023; 7(8): 158-177 

© 2023 | Published by Scholars Middle East Publishers, Dubai, United Arab Emirates                                                                                       162 

 
 

2. Fill Quick Grid Lines 

 

 
Fig. 4: Defining dimensional data 

 

3. Define > Section Properties> Link Support Type 

Multi Linear Plastic> Link/Support Properties > 

Fill Directional Properties > Properties Modify/ 

Show For U2 > Hysteresis Type >Fill Stiffness & 

Damping> Multi Linear Force Deformation 

Definition 

 

 
Fig. 5: Defining Link/Support Properties 
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4. Draw > Draw 2 Joint Link > Complete Lump Model 

 

 
Fig. 6: Lumped-Mass Model for analysis 

 

5. Select bottom most lower point > Assign > Joint > Restraints > Fixed Support 

 

 
Fig. 7: Assign support 

 

6. Assign > Joint > Masses > Specify Joint Mass > As Weight > Mass Coordinate System > Global > Fill Mass as 

Translation Global X 

 

 
Fig. 8: Assign mass of different layers 
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7. Define > function > Time history > Choose Function Type to Add from File > Add new function > Browse & Select 

given file 

 

 
Fig. 8: Defining time history data 

 

8. Load Cases > Add New Load Cases > Load Case 

Type Time History > Analysis Type NonLinear> 

History Type Transient > Solution Type Modal > 

Select Load Type, Load Name, Function, Scale 

Factor > Fill Number of Output Time Steps, Output 

Time Step Size 

 

 
Fig. 9: Defining Linear Modal History 
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9. Load Cases >Modal > Modify/Show Load Cases >Types of Modes Ritz Vectors > Fill Maximum no of Modes > 

Assign Load Applied  

 

 
Fig. 10: Defining modes for modal analysis 

 

10. Analyze > Run Analysis  

11. Display > Show Plot Functions > Define Plot 

Function > Choose Function to Add to Joint 

Disps/Forces > Add Plot Function > Fill Joint ID, 

Vector Type, Component 

 

 
Fig. 11: Defining displacement versus time plot 

 

12. Display > Show Table > Analysis results > Structure Output > Modal Information > Modal Periods & Frequencies > 

Select Load Cases  
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Fig. 12: Display modal periods & frequencies 

 

Results for Sub-Structure Lumped Mass (Nonlinear Analysis): 

 

Table 2: Load vs. Displacement for Series 1 & 2 

Series 1 Series 2 

Displacement, mm Force, kN Stiffness, kN/m Displacement, mm Force, kN Stiffness, kN/m 

-70 -10 142.86 -70 -20 285.71 

-68 -10 147.06 -68 -20 294.12 

-61 -10 163.93 -61 -20 327.87 

-53 -10 188.68 -53 -20 377.36 

-47 -10 212.77 -47 -20 425.53 

-38 -10 263.16 -38 -20 526.32 

-32 -10 312.50 -32 -20 625.00 

-27 -10 370.37 -27 -20 740.74 

-20 -10 500.00 -20 -20 1000.00 

-15 -10 666.67 -15 -20 1333.33 

-10 -10 1000.00 -12 -20 1666.67 

-5 -10 2000.00 -10 -20 2000.00 

0 0 0.00 0 0 0.00 

5 10 2000.00 10 20 2000.00 

10 10 1000.00 12 20 1666.67 

15 10 666.67 15 20 1333.33 

20 10 500.00 20 20 1000.00 

27 10 370.37 27 20 740.74 

32 10 312.50 32 20 625.00 

38 10 263.16 38 20 526.32 

47 10 212.77 47 20 425.53 

53 10 188.68 53 20 377.36 

61 10 163.93 61 20 327.87 

68 10 147.06 68 20 294.12 

70 10 142.86 70 20 285.71 
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Fig. 13: Load vs. Deformation curve for Series 1 & 2 

 

Lumped Mass Nodes No for Both Series 1 & 2 

 

 

 
Fig. 14: 3D model for MDOF 
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Series 1 (Joint 2) 

 

Series 2 (Joint 2) 

 
Series 1 (Joint 3) 

 

Series 2 (Joint 3) 

 
Fig. 15: Displacement vs. Time for Joint 1 & 2 (Nonlinear Analysis - Series 1 & 2) 

 

Series 1 (Joint 4) Series 2 (Joint 4) 

  
Series 1 (Joint 5) Series 2 (Joint 5) 

  
Fig. 16: Displacement vs. Time for Joint 4 & 5 (Nonlinear Analysis - Series 1 & 2) 
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Series 1 (Joint 6) Series 2 (Joint 6) 

  
Series 1 (Joint 7) Series 2 (Joint 7) 

 
 

Fig. 17: Displacement vs. time for joint 6 & 7 (Nonlinear Analysis - Series 1 & 2) 

 

Series 1 (Joint 8) Series 2 (Joint 8) 

  
Series 1 (Joint 9) Series 2 (Joint 9) 

  
Fig. 18: Displacement vs. Time for Joint 8 & 9 (Nonlinear Analysis - Series 1 & 2) 
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Series 1 (Joint 10) Series 2 (Joint 10) 

  
Series 1 (Joint 11) Series 2 (Joint 11) 

  
Fig. 19: Displacement vs. Time for Joint 10 & 11 (Nonlinear Analysis - Series 1 & 2) 

 

Series 1 (Joint 12) Series 2 (Joint 12) 

  
Series 1 (Joint 13) Series 2 (Joint 13) 

  
Fig. 20: Displacement vs. Time for Joint 12 & 13 (Nonlinear Analysis - Series 1 & 2) 
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Table 3: Displacement Results vs. Time for Series 1 & 2 (Nonlinear Analysis) 

 
 

Table 4: Load vs. Displacement for Series 3 and 4 

Series 3 

Displacement, mm Force, kN Stiffness, kN/m 

-70 -30 428.57 

-68 -30 441.18 

-61 -30 491.80 

-53 -30 566.04 

-47 -30 638.30 

-38 -30 789.47 

-32 -30 937.50 

-27 -30 1111.11 

-20 -30 1500.00 

-15 -30 2000.00 

-12 -30 2500.00 

-10 -30 3000.00 

0 0 0.00 

10 30 3000.00 

12 30 2500.00 

15 30 2000.00 

20 30 1500.00 

27 30 1111.11 

32 30 937.50 

38 30 789.47 

47 30 638.30 

53 30 566.04 

61 30 491.80 

68 30 441.18 

70 30 428.57 
 

Series 4 

Displacement, mm Force, kN Stiffness, kN/m 

-70 -40 571.43 

-68 -40 588.24 

-61 -40 655.74 

-53 -40 754.72 

-47 -40 851.06 

-38 -40 1052.63 

-32 -40 1250.00 

-27 -40 1481.48 

-20 -40 2000.00 

-15 -40 2666.67 

-12 -40 3333.33 

-10 -40 4000.00 

0 0 0.00 

10 40 4000.00 

12 40 3333.33 

15 40 2666.67 

20 40 2000.00 

27 40 1481.48 

32 40 1250.00 

38 40 1052.63 

47 40 851.06 

53 40 754.72 

61 40 655.74 

68 40 588.24 

70 40 571.43 
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Fig. 21: Load vs. Deformation curve for Series 3 and 4 

 

Series 3 (Joint 2) Series 4 (Joint 2) 

  
Series 3 (Joint 3) Series 4 (Joint 3) 

  
Fig. 22: Displacement vs. Time for Joint 2 & 3 (Nonlinear Analysis - Series 3 and 4) 
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Series 3 (Joint 4) Series 4 (Joint 4) 

  
Series 3 (Joint 5) Series 4 (Joint 5) 

  
Fig. 23: Displacement vs. Time for Joint 4 & 5 (Nonlinear Analysis - Series 3 & 4) 

 

Series 3 (Joint 6) Series 4 (Joint 6) 

  
Series 3 (Joint 7) Series 4 (Joint 7) 

  
Fig. 24: Displacement vs. Time for Joint 6 & 7 (Nonlinear Analysis - Series 3 & 4) 
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Series 3 (Joint 8) Series 4 (Joint 8) 

  
Series 3 (Joint 9) Series 4 (Joint 9) 

 
 

Fig. 25: Displacement vs. Time for Joint 8 & 9 (Nonlinear Analysis - Series 3 & 4) 

 

Series 3 (Joint 10) Series 4 (Joint 10) 

  
Series 3 (Joint 11) Series 4 (Joint 11) 

  
Fig. 26: Displacement vs. Time for Joint 10 & 11 (Nonlinear Analysis - Series 3 & 4) 
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Series 3 (Joint 12) Series 4 (Joint 12) 

  
Series 3 (Joint 13) Series 4 (Joint 13) 

  
Fig. 27: Displacement vs. Time for Joint 12 & 13 (Nonlinear Analysis - Series 3 & 4) 

 

Table 5: Displacement Results vs. Time for Series 3 & 4 (Nonlinear Analysis) 
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Table 6: Maximum and Minimum Displacement Results (Nonlinear Analysis) 

 
 

Table 7: Permanent Deformations (mm) 

Model Series 1 Series 2 Series 3 Series 4 

Joint 2 3.0 -3.3 -2.6 0.0 

Joint 3 -1.5 -4.5 -4.3 0.0 

Joint 4 -4.8 -4.0 -4.0 0.0 

Joint 5 -7.0 -3.0 -4.0 0.0 

Joint 6 -6.5 -3.0 -4.0 0.0 

Joint 7 -5.5 -1.2 -4.0 0.0 

Joint 8 -5.0 -0.5 -4.0 0.0 

Joint 9 -9.5 -0.5 -4.0 0.0 

Joint 10 -9.5 -0.5 -3.0 0.0 

Joint 11 -9.5 -0.5 -3.0 0.0 

Joint 12 -9.5 -0.5 -3.0 0.0 

Joint 13 -9.5 -0.5 -3.0 0.0 

 

Table 7 shows permanent deformations at 

different joints of the four nonlinear models (Series 1, 

2, 3 and 4). The large permanent deformations of Series 

1 (most flexible) and no permanent deformation of 

Series 4 (most rigid) are to be noted. 

 

DISCUSSION 
Lumped-mass model is found reasonably 

accurate and suitable for nonlinear analysis due to 

ground motion. This is used for subsequent nonlinear 

analysis models.  

 

First, two series (Series 1 and 2) of load vs. 

displacement hysteresis loops are assumed for nonlinear 

analysis. Permanent deformations take place in both 

cases which cause tilting of buildings. Then two more 

series (Series 3 and 4) of load vs. displacement 

hysteresis loops are assumed for nonlinear analysis. 

Here permanent deformation has been found for Series 

3 (although smaller than Series 1) but no deformation 

has been observed for Series 4. 

 

CONCLUSION 
This thesis shows the nonlinear behavior 

deformation results of numerical analysis of soil mass 

during earthquake. Principal concentration of this study 

is to find out the permanent deformation takes place 

during earthquake which may cause tilting of the 

building. Lumped soil mass can be used to understand 

the behavior of soil mass during earthquake. 

Amplification of soil is higher near surface. It indicates 

the effect of earthquake. If the stiffness of the soil is 

high then deformation starts with relatively small 

values. Deformation indicates elastic strain is small 

compared to plastic strain. Sometimes, it can take more 

time than ground motion time to settle down the 
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vibration of the soil mass due to slender effect. Soil 

parameters play a very important role in case of the 

behavior of soil mass during earthquake. Failure of soil 

mass during earthquake is of the main cause of tilting of 

the buildings. Permanent deformation is observed for 

nonlinear elastic, perfectly plastic hysteresis loops. If 

the stiffness of the soil is higher than permanent 

deformation may not take place. 
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